[Webkit-unassigned] [Bug 42857] Inefficient Handling of Shift and Unshift

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 26 16:17:25 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=42857


Gavin Barraclough <barraclough at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #62360|review?                     |review-
               Flag|                            |




--- Comment #2 from Gavin Barraclough <barraclough at apple.com>  2010-07-26 16:17:25 PST ---
(From update of attachment 62360)
Please revert unnecessary change to JavaScriptCore/Configurations/JavaScriptCore.xcconfig.

There are a couple of these:
    BaseIndex(regT2, regT1, ScalePtr, 0)
You should just remove the last ",0", this is not necessary.

In JSArray.h, typo: "qucik"
    "return (ArrayStorage *)((char*)" - these should be c++ style casts.

in ArrayPrototype.cpp:
    We have a coding style rule that we don't use abbreviations, unless it is canonically understood.  I don't think the 'nr' in nrArgs matches the style in the codebase well, and I think it falls foul of this rule.  We do commonly use the abbreviations 'args' and 'num' for number.  I'd suggest numArgs, numberOfArgs, argsCount, etc could all be acceptable, but I think 'nr' should change.  I'd also prefer 'index' to 'k' as the loop counter, but single character loop index names clearly has precedent.

Otherwise, all looks great – normally I'd r+, but I'll r- despite the small number of changes since you'll be needing to put up a new patch for the commit-queue anyway.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list