[Webkit-unassigned] [Bug 40197] Enhance the hit testing to take a rectangle instead of a point

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 23 12:25:25 PDT 2010


Dave Hyatt <hyatt at apple.com> changed:

           What    |Removed                     |Added
  Attachment #62453|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |

--- Comment #46 from Dave Hyatt <hyatt at apple.com>  2010-07-23 12:25:24 PST ---
(From update of attachment 62453)
"void static dumpHitTestResult(const HitTestResult& result)"

I really don't like this function sitting in Document.  It has nothing to do with Document.  I'd prefer it either be removed or put in more of a debugging file (if it's a bit like render tree dumping especially).  It really seems to me like it should just be removed, especially if nodesFromRect is testable via layout tests.

Let's use 0,0 as the default value for padding instead of -1,-1 and make rect-based hit testing be activated if either value of padding is > 0 (rather than >= 0).  We don't want to fall into rect-based hit testing because somebody passed 0 values for padding in to these functions.

Everything else looks good to me.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list