[Webkit-unassigned] [Bug 42767] [Windows] Home hey doesn't work in first DIV inside a TABLE

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 22 14:16:34 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=42767





--- Comment #9 from Ryosuke Niwa <rniwa at webkit.org>  2010-07-22 14:16:34 PST ---
(In reply to comment #8)
> (From update of attachment 62320 [details])
> Just a couple more small things.
> 
> > +++ LayoutTests/resources/dump-as-markup.js	(working copy)
> > +    if (typeof opt_node == 'string') {
> > +        // Allow to specify the node by id and to pass the description in the first argument
> > +        if (document.getElementById(opt_node))
> > +            opt_node = document.getElementById(opt_node);
> > +        else {
> > +            opt_node = null;
> > +            opt_description = opt_node;
> > +        }
> 
> Why do we have this else clause? If opt_node is a string and the node is not in the document, we should just error.

What if I've already called setNodeToDump and just want to pass-in the description?  Then I have to specify the node again in order to dump a subtree.  So I added that else clause to allow the description being passed through opt_node.

> > +    if (Markup._test_description && !Markup._container)
> > +        markup += Markup._test_description + '\n';
> > +
> > +    Markup._dumpCalls++;
> > +
> > +    // If dump is called not by notifyDone or dump has already been called then
> > +    // print out optional description because this is a test with multiple calls of dump.
> > +    if (!Markup._done || opt_description) {
> > +        if (!opt_description)
> > +            opt_description = "Dump of markup " + Markup._dumpCalls
> > +        if (Markup._container)
> 
> Checking Markup._container here and above is a bit confusing to me. How about checking that Markup._dumpCalls > 1? That should have the same effect, right?

Will do.

> > +            markup += '\n';
> > +        markup += '\n' + opt_description;
> 
> Nit: Can you add add a colon after the description? I think it makes the output a bit more readable.

Will do.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list