[Webkit-unassigned] [Bug 42426] Implement remaining Inspector support for chrome's appcache

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 21 21:59:27 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=42426





--- Comment #21 from Michael Nordman <michaeln at google.com>  2010-07-21 21:59:26 PST ---
(From update of attachment 62253)
WebKit/chromium/src/ApplicationCacheHost.cpp:213
 +  ApplicationCacheHost::CacheInfo ApplicationCacheHost::applicationCacheInfo()
Sorry i didn't notice this before. These two new methods should in an #if ENABLE(INSPECTOR) block to match the .h file.

WebKit/chromium/src/ApplicationCacheHost.cpp:232
 +          KURL(webResources[i].url), webResources[i].isMaster, webResources[i].isManifest, webResources[i].isFallback,
Having this line indent to the same level as the preceding line catches my eye. 

230     for (int i = 0; i < webResources.size(); ++i) {
231         resources->append(ResourceInfo(
232              webResources[i].url, webResources[i].isMaster, webResources[i].isManifest, webResources[i].isFallback,
233              webResources[i].isForeign, webResources[i].isExplicit, webResources[i].size));
234     }

Also, class WebURL has a KURL() operator so i don't think we need to explicitly invoke the KURL ctor. WebURL intentionally has a cast operator just for this purpose, so the resulting code is easier to read with less conversion code obscuring things.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list