[Webkit-unassigned] [Bug 42534] Crash in Notification::disconnectFrame() triggered by Frame::lifeSupportTimerFired()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 21 10:47:33 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=42534


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #62209|review?                     |review-
               Flag|                            |




--- Comment #18 from Darin Adler <darin at apple.com>  2010-07-21 10:47:33 PST ---
(From update of attachment 62209)
> +    // Due to the misterious bug http://code.google.com/p/chromium/issues/detail?id=49323.

Spelling error here: "misterious".

> +void DOMWindow::disconnectNotifications()

This function should be named after when it's called, the event the DOMWindow is learning about, rather than what it does. I think pageDestroyed is a fine name for it. It should not be notifications-specific. The body can be, but the function itself should not.

> +#if ENABLE(NOTIFICATIONS)
> +    if (m_domWindow)
> +        m_domWindow->disconnectNotifications();
> +#endif

Then this could be:

    if (m_domWindow)
        m_domWindow->pageDestroyed();

Please make those changes.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list