[Webkit-unassigned] [Bug 42651] prefetch categorization is exactly wrong

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 20 15:10:03 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=42651


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #62118|1                           |0
        is obsolete|                            |




--- Comment #7 from Darin Adler <darin at apple.com>  2010-07-20 15:10:03 PST ---
(From update of attachment 62118)
Why does the test say it requires DumpRenderTree? I don’t see anything in the test that requires it. Why doesn’t the test explain what success looks like and what failure looks like?

A good test explains what it tests, and makes failure vs. success clear.

Fix is fine, although I'd prefer to make the #if even cleaner by putting the body outside the class definition:

    inline bool CachedResource::isPrefetch() const
    {
    #if ENABLE(LINK_PREFETCH)
        return type() == LinkPrefetch;
    #else
        return false;
    #endif
    }

Then the class definition will be easier to read.

review- just because it seems the test could be much clearer

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list