[Webkit-unassigned] [Bug 42479] [Chromium] Implement WebFormElement::userSubmitted().

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jul 17 20:54:18 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=42479





--- Comment #5 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2010-07-17 20:54:17 PST ---
(From update of attachment 61843)
WebCore/html/HTMLFormElement.cpp:409
 +      // common browsers( sick! ) allow it be canceled.
both spellings are correct according to the dictionary.  probably
better to leave the existing code unchanged.

WebKit/chromium/src/WebFormElement.cpp:71
 +      return constUnwrap<HTMLFormElement>()->submissionTrigger() == NotSubmittedByJavaScript;
are you sure you don't want to expose an enum for the variety
of submission trigger types?

WebKit/chromium/src/WebFormElement.cpp:69
 +  bool WebFormElement::userSubmitted() const
I'm having a hard time understanding what this method name implies.  Is
this telling me that the user already submitted this form?  what happens
if the form is submitted multiple times (e.g., suppose it has a target
that corresponds to an IFRAME)?  what if the form is submitted once by
javascript and then once by user action?

what if the user clicks on a link, and some javascript runs, which
then calls form.submit()?  would that be regarded as a non-user
submitted form?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list