[Webkit-unassigned] [Bug 42076] Keyboard operations for <input type=number>

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 16 14:55:44 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=42076


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED




--- Comment #5 from Kent Tamura <tkent at chromium.org>  2010-07-16 14:55:44 PST ---
Thank you for reviewing.

(In reply to comment #4)
> WebCore/html/HTMLInputElement.cpp:2131
> > +      }
> nit: please add a new line before the "if (isTextField()..."

Done.

> WebCore/html/HTMLInputElement.cpp:2119
> > +      if (hasSpinButton() && evt->type() == eventNames().keydownEvent && evt->isKeyboardEvent()) {
> nit: maybe it is better to put the isTextField case about the spin button
> case since text fields are probably more common than spin buttons?

Did not.  It's possible that non-textfield has spin buttons in the future.

> WebCore/html/HTMLInputElement.cpp:2121
> > +          if (key == "Up") {
> nit: how about using a temporary to avoid having to repeat the
> work of calling those functions twice?

Done.

> WebCore/html/HTMLInputElement.cpp:2399
> > +  static bool isNumberCharacter(UChar ch)
> nit: normally better to put static helper functions at the top of the file.
> that way the flow of HTMLInputElement methods is not interrupted by a non-
> member function implementation.

Moved it to the top.


Landed as http://trac.webkit.org/changeset/63586

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list