[Webkit-unassigned] [Bug 41129] CSSSelector: Avoid chaining tagHistory of CSSSelector, which causes stack overflow.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 14 09:59:33 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=41129





--- Comment #19 from Darin Adler <darin at apple.com>  2010-07-14 09:59:33 PST ---
(In reply to comment #18)
>     class SelectorDeque {
>     public:
>         bool isEmpty() const;
>         PassOwnPtr<CSSSelector> takeFirst();
>         void append(PassOwnPtr<CSSSelector>);
>     };

Oops, but it would not be a Deque, so it should be named something more like SelectorBag.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list