[Webkit-unassigned] [Bug 40775] Table Cell Layering

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 9 13:24:34 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=40775


Dave Hyatt <hyatt at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #60647|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #19 from Dave Hyatt <hyatt at apple.com>  2010-07-09 13:24:34 PST ---
(From update of attachment 60647)
We tend to avoid "get" in method names in the render tree, so instead of getPrimaryCellAt, just make the method primaryCellAt. This is more consistent with primaryCell() anyway.

Please revert your changes to RenderTableCell.cpp.  It looks like you just messed with whitespace there without making any real changes.

RenderTableSection::comparelayers... function names are always intercaps, so that should be compareLayers.  I still think you need to avoid using the term "layer" though, since that's very confusing.  Just rename to compareCellPositions.

I think the implementation of primaryCell is a little weird duplicated.  Maybe you could at least compact it to:

return hasCells() ? cells[cells.size() - 1] : 0;

That's one line instead of three and doesn't look so bad used twice. :)

The RenderTableSection member, Vector<RenderTableCell*> m_Cells, does not appear to be used unless I'm missing something.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list