[Webkit-unassigned] [Bug 41608] DeviceOrientation should be renamed to DeviceOrientationController

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 7 02:46:35 PDT 2010


Adam Barth <abarth at webkit.org> changed:

           What    |Removed                     |Added
  Attachment #60539|review?                     |review+
               Flag|                            |

--- Comment #4 from Adam Barth <abarth at webkit.org>  2010-07-07 02:46:35 PST ---
(From update of attachment 60539)
 +      // FIXME: Add methods to start and stop the service.
This patch will make more sense once we do this FIXME.

It's not really controlling the DeviceOrientation, is it?  That would be kind of awesome.  Instead, it's controlling the DeviceOrientation service, right?  I guess the GeolocationController isn't controlling the geolocation either.  I guess brevity is a virtue here and DeviceOrientationServiceController is too long...

Anyway, not 100% cheesed about the name.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list