[Webkit-unassigned] [Bug 41608] New: DeviceOrientation should be renamed to DeviceOrientationController

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 5 05:15:35 PDT 2010


           Summary: DeviceOrientation should be renamed to
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebCore Misc.
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: steveblock at google.com
                CC: jorlow at chromium.org, hans at chromium.org
            Blocks: 41607

This is consistent with other controllers, eg Geolocation, and will allow the name DeviceOrientation to be used to represent a set of device orientation data. This will be cleaner than passing around the 3 bools and 3 doubles required to represent the optional properties of the DeviceOrientationEvent.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list