[Webkit-unassigned] [Bug 40793] [GTK] The size of the shadow image uses the standard deviation size instead of the blur radius

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jul 3 05:47:44 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=40793





--- Comment #7 from Dirk Schulze <krit at webkit.org>  2010-07-03 05:47:44 PST ---
(In reply to comment #6)
> (In reply to comment #5)
> >
> > [...]
> >
> > I'm quite sure, that this need updates of pixel tests. Can you run layout tests with a tolerance of zero please?
> 
> Yep, the visual result is different, I was wondering if other platforms with pixel tests for this filter could have problems because I could not test it in webkitgtk+. I'll review what we need.
> 
> > I'm also not sure about kernelPosition. The spec for feGaussianBlur changed recently and a blurring radius of 0 is allowed now. If a stdDeviation for any direction is zero, the image is just not blurred for this direction. At the moment we break and don't draw the blurring at all.
> 
> I understand, we can change also this condition that controls the standard deviation parameter:
> 
>     if (m_x == 0 || m_y == 0)
>         return;
> 
> with
> 
>     if (m_x == 0 && m_y == 0)
>         return;
The result of the filter, if stdDeviation is 0 for all sizes, is as if no filter was applied at all. that means input = output. With if (m_x == 0 && m_y == 0) the output is transparent black, independent of the input. The spec changed lately and noone removed this check up to now.

> 
> And add ifs to the calculations to avoid calculating sdx or sdy and avoid the blox blur in that direction.
> 
> Probably the name of the parameters/variables are still confusing, I could change m_x and m_y with mStdx and mStdy, and sdx/sdy with kernelSizex/kernelSizey.
For private variables of a class we use m_... as prefix. But of course you can rename it to something like m_stdX and m_stdY.

> I'll do, thanks very much for the review Dirk :).
Thank you for working on this problem :-)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list