[Webkit-unassigned] [Bug 41529] Add the ability for user scripts and user styles to affect just the top frame

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 2 14:40:35 PDT 2010


--- Comment #4 from Aaron Boodman <aa at chromium.org>  2010-07-02 14:40:35 PST ---
Agreed. (In reply to comment #2)
> (From update of attachment 60390 [details])
> WebKit/chromium/public/WebView.h:298
>  +                                           bool runAtStart,
> a string of bool parameters is fairly bad for readability.  the better
> approach is to define enums.  you should just define enums that match
> the WebCore enums.  use AssertMatchingEnums.cpp to help so that you can
> just cast between WebCore and WebKit API enums.

Agreed. Take another look?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list