[Webkit-unassigned] [Bug 41286] [chromium] EditorClient should forward text field related calls to the WebViewClient

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 2 13:38:35 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=41286


Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #59930|review?                     |review-
               Flag|                            |




--- Comment #3 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2010-07-02 13:38:35 PST ---
(From update of attachment 59930)
WebKit/chromium/src/EditorClientImpl.cpp:823
 +      HTMLInputElement* inputElement = WebKit::toHTMLInputElement(element);
EditorClientImpl is defined in the WebKit namespace, so you don't
need to have the WebKit:: prefix before toHTMLInputElement.

WebKit/chromium/public/WebViewClient.h:146
 +      virtual void textFieldHandlingKeyDown(const WebInputElement&, const WebKeyboardEvent&) { }
textFieldDidReceiveKeyDown?

WebKit/chromium/public/WebViewClient.h:144
 +      virtual void textDidChangeInTextField(const WebInputElement&) { }
textFieldDidChange?

WebKit/chromium/public/WebInputElement.h:83
 +          WEBKIT_API bool readOnly() const;
hmm... maybe this should be named isReadOnly to match isEnabledFormControl.
i know you are just replicating readOnly from the WebCore name.

looks good otherwise.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list