[Webkit-unassigned] [Bug 33750] Add back an AffineTransform class for use by SVG
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sun Jan 31 12:41:54 PST 2010
https://bugs.webkit.org/show_bug.cgi?id=33750
--- Comment #12 from Dirk Schulze <krit at webkit.org> 2010-01-31 12:41:51 PST ---
(In reply to comment #11)
> Attachment 47797 [details] did not pass style-queue:
I won't fix the mentioned style issues with the following reasons:
>
> Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1
> Last 3072 characters of output:
> ontextSkia.cpp:821: One space before end of line comments
> [whitespace/comments] [5]
> WebCore/platform/graphics/skia/GraphicsContextSkia.cpp:822: One space before
> end of line comments [whitespace/comments] [5]
> WebCore/platform/graphics/skia/GraphicsContextSkia.cpp:823: One space before
> end of line comments [whitespace/comments] [5]
Looks like a style decission of the chromium guys and it makes sense here for a
better code reading.
> WebCore/platform/graphics/skia/TransformationMatrixSkia.cpp:31: Found other
> header before a header this file implements. Should be: config.h, primary
> header, blank line, and then alphabetically sorted. [build/include_order] [4]
AffineTransform is also a primary header. The names of
TransformationMatrix*.cpp might change to AffineTransform*.cpp later.
> WebCore/platform/graphics/cairo/PathCairo.cpp:333: c_matrix is incorrectly
> named. Don't use underscores in your identifier names. [readability/naming]
Gtk port uses underscores for variables.
> [4]
> WebCore/platform/graphics/transforms/AffineTransform.cpp:118: Tests for
> true/false, null/non-null, and zero/non-zero should all be done without
> equality comparisons. [readability/comparison_to_zero] [5]
> WebCore/platform/graphics/transforms/AffineTransform.cpp:119: Tests for
> true/false, null/non-null, and zero/non-zero should all be done without
> equality comparisons. [readability/comparison_to_zero] [5]
> WebCore/platform/graphics/transforms/AffineTransform.cpp:129: Tests for
> true/false, null/non-null, and zero/non-zero should all be done without
> equality comparisons. [readability/comparison_to_zero] [5]
> WebCore/platform/graphics/transforms/AffineTransform.cpp:135: Tests for
> true/false, null/non-null, and zero/non-zero should all be done without
> equality comparisons. [readability/comparison_to_zero] [5]
It's necessary to check for 0 here, since values are allowed to be negative.
> WebCore/platform/graphics/qt/TransformationMatrixQt.cpp:27: Found other header
> before a header this file implements. Should be: config.h, primary header,
> blank line, and then alphabetically sorted. [build/include_order] [4]
see above
> WebCore/platform/graphics/cg/TransformationMatrixCG.cpp:27: Found other header
> before a header this file implements. Should be: config.h, primary header,
> blank line, and then alphabetically sorted. [build/include_order] [4]
see above
> WebCore/platform/graphics/wx/TransformationMatrixWx.cpp:27: Found other header
> before a header this file implements. Should be: config.h, primary header,
> blank line, and then alphabetically sorted. [build/include_order] [4]
see above
> WebCore/platform/graphics/cairo/TransformationMatrixCairo.cpp:26: Found other
> header before a header this file implements. Should be: config.h, primary
> header, blank line, and then alphabetically sorted. [build/include_order] [4]
see above
> WebCore/platform/graphics/cairo/TransformationMatrixCairo.cpp:50:
> cairo_matrix_t is incorrectly named. Don't use underscores in your identifier
> names. [readability/naming] [4]
Style guide of the gtk port.
> WebCore/platform/graphics/cairo/TransformationMatrixCairo.cpp:54: Extra space
> before ( in function call [whitespace/parens] [4]
Style decission of the gtk port.
> WebCore/platform/graphics/transforms/AffineTransform.h:130: Missing spaces
> around *= [whitespace/operators] [3]
Found it that way in all other headers for operator like FloatPoint, Size, Rect
as well as TransformationMatrix and others. Maybe also a false positive?
> WebCore/platform/graphics/transforms/AffineTransform.h:147: cairo_matrix_t is
> incorrectly named. Don't use underscores in your identifier names.
> [readability/naming] [4]
see above
> Total errors found: 19
>
>
> If any of these errors are false positives, please file a bug against
> check-webkit-style.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list