[Webkit-unassigned] [Bug 33957] [v8] Implement Node map in intrusive way for better speed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 25 16:21:26 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=33957


Adam Barth <abarth at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #47372|review?                     |review+
               Flag|                            |




--- Comment #11 from Adam Barth <abarth at webkit.org>  2010-01-25 16:21:24 PST ---
(From update of attachment 47372)
+ m_table()

You don't need to call the default constructor explicitly.

+ static int const kNoEntries = (1 << 10) - 1;

Perhaps numberOfEntries?  (WebKit-land doesn't use "k" and the No is
confusing).

Thanks for factoring ChunkedTable out.  It's much easier to follow what's going
on abstractly.  As we discussed, we should move ChunkedTable to a more generic
location in a future patch.

Looks great!  I wish we had some unit testing for ChunkedTable, but that's not
the way WebKit rolls.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list