[Webkit-unassigned] [Bug 34003] [GTK] Pass cookies to GStreamer

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 22 09:19:46 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=34003


Gustavo Noronha (kov) <gns at gnome.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #47203|review?                     |review-
               Flag|                            |




--- Comment #4 from Gustavo Noronha (kov) <gns at gnome.org>  2010-01-22 09:19:46 PST ---
(From update of attachment 47203)
In addition to the style checker output (which seems valid for the case), I
have the following comments:

 132     g_object_get (mp->m_playBin, "source", &element, NULL);
 133     old_element = mp->m_source;
 134     mp->m_source = NULL;

The old_element variable (besides having a bad name given the style) seems to
be unnecessary. You could check, and unref mp->m_source directly instead of
assigning it to another variable.

 135     if (old_element)
 136         gst_object_unref (old_element);
 137     mp->m_source = element;

This looks like a crash - we are not refing the element ourselves (perhaps we
should), so unreffing it seems wrong (the same goes for the destructor).

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list