[Webkit-unassigned] [Bug 33964] Added RenderMathMLBlock as based object for MathML

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 21 14:25:24 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=33964


Dave Hyatt <hyatt at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #47135|review?                     |review-
               Flag|                            |




--- Comment #2 from Dave Hyatt <hyatt at apple.com>  2010-01-21 14:25:24 PST ---
(From update of attachment 47135)
In RenderMathMLBlock::styleDidChange, why are you marking the block as needing
layout and pref width recalc always?  That's really inefficient. I'm also not
clear on wny it's necessary.  Isn't the style diff doing the right thing in the
base classes?

In isChildAllowed you don't have to do ? true : false.  Just return the
conditional itself.

stretchToHeight would be cleaner using a for loop to walk the children in my
opinion.

for (RenderObject* current = firstChild(); current; current =
current->nextSibling());

It seems like makeBlockStyle should return a PassRefPtr, since you're wanting
to have it be set on some RenderObject presumably.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list