[Webkit-unassigned] [Bug 16318] Insufficient repaint issues with html embedded in foreignObject
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Jan 20 21:00:33 PST 2010
https://bugs.webkit.org/show_bug.cgi?id=16318
mitz at webkit.org changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #47096|review? |review+
Flag| |
--- Comment #10 from mitz at webkit.org 2010-01-20 21:00:32 PST ---
(From update of attachment 47096)
> +IntRect RenderListMarker::localSelectionRect()
> +{
> + InlineBox* box = inlineBoxWrapper();
> + if (!box)
> + return IntRect();
> + RootInlineBox* root = box->root();
> + if (!root)
> + return IntRect();
No need to null-check root.
> + IntRect localSelectionRect();
You should use this new function in selectionRectForRepaint() too instead of
having duplicated code.
r=me but please do ^ if possible.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list