[Webkit-unassigned] [Bug 33866] New: Refactor JITStubs.cpp so that DEFINE_STUB_FUNCTION is only used once for each function
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jan 19 13:57:22 PST 2010
https://bugs.webkit.org/show_bug.cgi?id=33866
Summary: Refactor JITStubs.cpp so that DEFINE_STUB_FUNCTION is
only used once for each function
Product: WebKit
Version: 528+ (Nightly build)
Platform: PC
OS/Version: All
Status: NEW
Severity: Normal
Priority: P2
Component: JavaScriptCore
AssignedTo: webkit-unassigned at lists.webkit.org
ReportedBy: laszlo.1.gombos at nokia.com
Place the guard USE(JSVALUE32_64) inside the body of the DEFINE_STUB_FUNCTION
macro. This I think makes the code a bit more readable as it is clear that
DEFINE_STUB_FUNCTION(int, op_eq) is needed regardless of the USE(JSVALUE32_64)
test.
This refactoring fixes a build break for the RVCT tool chain. For the RVCT
toolchain (e.g. for Symbian) precompiler macros are not expanded before the
code is passed to the assembler. This tool chain limitation and the
corresponding workaround (simple perl script as pre-compiler) been documented
as part of commit r52970.
The current perl script does not take all the C precompiler macros into
account, so it expands the DEFINE_STUB_FUNCTION macro twice for
DEFINE_STUB_FUNCTION(int, op_eq).
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list