[Webkit-unassigned] [Bug 33364] [Chromium] Should not select a word on right-click in editable text

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 15 00:58:00 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=33364





--- Comment #14 from TAMURA, Kent <tkent at chromium.org>  2010-01-15 00:57:59 PST ---
> > +    virtual void replaceWord(const WebString& text) = 0;
> 
> I think you should give this function a more descriptive name.  I'm also
> concerned that it has the side-effect of altering the selection.  Perhaps
> for the WebKit API we should really break this up.  We already have a
> hasSelection() method, so it seems like you could just add a method
> that causes selection to be set at the word around the caret.  Like this:
> 
>   virtual void selectWordAroundCaret() = 0;

ok, I renamed so.

> > +    // Should have a caret or a ranged selection because the corrected word was
> > +    // based on them. See selectMisspelledWord() in ContextMenuClientImpl.cpp.
> > +    ASSERT(!controller->isNone());
> 
> It seems like there could be a race here.  Do we allow events to be processed
> between the time selectMisspelledWord is called and the time that replaceWord
> is called?

I confirmed this assertion was invalid.  JavaScript code can change the
selection during a context menu is opening.  Removed the assertion.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list