[Webkit-unassigned] [Bug 33648] Adds WebKit::WebSecurityOrigin::createFromDatabaseIdentifier.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Jan 13 23:07:36 PST 2010
https://bugs.webkit.org/show_bug.cgi?id=33648
Jeremy Orlow <jorlow at chromium.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
CC| |jorlow at chromium.org
--- Comment #2 from Jeremy Orlow <jorlow at chromium.org> 2010-01-13 23:07:36 PST ---
> Index: WebKit/chromium/ChangeLog
> ===================================================================
> --- WebKit/chromium/ChangeLog (revision 53232)
> +++ WebKit/chromium/ChangeLog (working copy)
> @@ -1,3 +1,13 @@
> +2010-01-13 Marcus Bulach <bulach at chromium.org>
> +
> + Reviewed by NOBODY (OOPS!).
> +
> + Adds WebKit::WebSecurityOrigin::createFromDatabaseIdentifier.
Need to add the bug number to the change log.
> Index: WebKit/chromium/public/WebSecurityOrigin.h
> ===================================================================
> --- WebKit/chromium/public/WebSecurityOrigin.h (revision 53224)
> +++ WebKit/chromium/public/WebSecurityOrigin.h (working copy)
> @@ -55,6 +55,8 @@ public:
> return *this;
> }
>
> + WEBKIT_API static WebSecurityOrigin* createFromDatabaseIdentifier(const WebString& database);
databaseIdentifier is probably a better name
> Index: WebKit/chromium/src/WebSecurityOrigin.cpp
> ===================================================================
> --- WebKit/chromium/src/WebSecurityOrigin.cpp (revision 53224)
> +++ WebKit/chromium/src/WebSecurityOrigin.cpp (working copy)
> @@ -42,6 +42,11 @@ namespace WebKit {
> class WebSecurityOriginPrivate : public SecurityOrigin {
> };
>
> +WebSecurityOrigin* WebSecurityOrigin::createFromDatabaseIdentifier(const WebString& database)
> +{
> + return new WebSecurityOrigin(SecurityOrigin::createFromDatabaseIdentifier(database));
ditto, ditto
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list