[Webkit-unassigned] [Bug 33178] Segmented SharedBuffer: SharedBuffer doesn't have to be a flat memory block

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 4 13:17:25 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=33178





--- Comment #4 from Yong Li <yong.li.webkit at gmail.com>  2010-01-04 13:17:25 PST ---
(In reply to comment #2)
> Attachment 45821 [details] did not pass style-queue:
> 
> Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1
> WebCore/platform/cf/SharedBufferCF.cpp:79:  Tests for true/false,
> null/non-null, and zero/non-zero should all be done without equality
> comparisons.  [readability/comparison_to_zero] [5]
> Total errors found: 1

-    ASSERT(m_buffer.size() == 0);
+    ASSERT(m_size == 0);

should be ok?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list