[Webkit-unassigned] [Bug 35213] [chromium] hardcoded gcc path breaks solaris build

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 22 00:02:36 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=35213


Evan Martin <evan at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #49162|review?                     |review-
               Flag|                            |




--- Comment #4 from Evan Martin <evan at chromium.org>  2010-02-22 00:02:36 PST ---
(From update of attachment 49162)
r- based on Darin's comments.  It looks like patch #3 has different changes
than patch #2.

-    open FILE, "-|", "/usr/bin/gcc", "-E", "-P", "-x", "objective-c", 
-        (map { "-D$_" } split(/ +/, $defines)), "-DOBJC_CODE_GENERATION",
$fileName or die "Could not open $fileName";
+    if (($Config::Config{'osname'})=~/solaris/i){
+        open FILE, "-|", "/usr/sfw/bin/gcc", "-E", "-P", "-x", "objective-c", 
+            (map { "-D$_" } split(/ +/, $defines)), "-DOBJC_CODE_GENERATION",
$fileName or die "Could not open $fileName";
+    } else {
+        open FILE, "-|", "/usr/bin/gcc", "-E", "-P", "-x", "objective-c", 
+            (map { "-D$_" } split(/ +/, $defines)), "-DOBJC_CODE_GENERATION",
$fileName or die "Could not open $fileName";
+    }

Rather than duplicate code, why not factor out the gcc path into a variable?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list