[Webkit-unassigned] [Bug 35146] [Qt] Support tiled backing store

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 19 05:50:20 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=35146





--- Comment #3 from Antti Koivisto <koivisto at iki.fi>  2010-02-19 05:50:20 PST ---

> > +void Frame::tiledBackingStorePaintBegin()
> > +{
> > +    if (!m_view)
> > +        return;
> > +    m_view->layoutIfNeededRecursive();
> > +    m_view->flushDeferredRepaints();
> > +}
> 
> I don't like these names very much, they don't seem to be only dealing with the
> tiled backing store.
> 
> > +void Frame::tiledBackingStorePaintEnd(const Vector<IntRect>& paintedArea)
> 
> So when you are finished painting, you have to inform where you painted? Maybe
> the API should reflect that?
> 
> 
> > +IntRect Frame::tiledBackingStoreContentRect()
> 
> IS there a difference between the contents rect and the actual rect of the
> backing store?

These methods are part of the abstract TiledBackingStoreClient interface and
are called by the TiledBackingStore. They need to be implemented by any class
that wants to be backed by the tiled backing store. This is needed for proper
layering as TiledBackingStore is a platform class can't know about FrameView.
In this context I don't understand your comments. 

(for example GraphicsLayers for accelerated compositing could use tiling too
far large layers).

> > +    void viewportChanged(const IntRect& viewportRect);
> 
> Frame uses setFrameRect, maybe setViewportRect?

Yeah.

> 
> > +    
> > +    float scale() { return m_scale; }
> > +    void setScale(float);
> 
> scale, zoom? so this actually scales the widgets?

Concept of zooming is already taken in WebKit. It is about zooming page by
changing the element sizes and relayouting. This is a different concept than
paint time transform based zooming here.

QPainter and graphics terminology in general uses "scale" for this.

> Shouldn't you put State as a suffix instead of as a prefix? Also, State doesn't
> say much, coudl we find a better name? What is StateNormal? Let's use a better
> name

Yep.

> > +    void dropOverhangingTiles();
> 
> What is overhanging?

Tiles that are at least partially outside the current document size (since
document got smaller).

> Why can't you use IntPoint? and maybe you should consider TilePoint?

One could argue that it is not really a point. The original reason was to have
a place to hang the hash function.

> More comments to follow, but I have a meeting now!

Have fun!

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list