[Webkit-unassigned] [Bug 33044] Add Java Applet support to WebKit's Qt port

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 18 02:36:07 PST 2010


--- Comment #11 from Garth Dahlstrom <ironstorm at gmail.com>  2010-02-18 02:36:07 PST ---
Created an attachment (id=48989)
 --> (https://bugs.webkit.org/attachment.cgi?id=48989)
Qt 4.6.2 Windows Java 1.6.0u17 Applet patch (Segfaults upon Java loading) --
Updated: Feb 18, 2010

I've tried to port the previous patch up to Qt 4.6.2.  

Unfortunately, it seg faults whenever a page with Java is hit.

Pretty sure the problem lies with either how
(\src\3rdparty\webkit\WebKit\qt\WebCoreSupport\FrameLoaderClientQt.cpp:1323) is
creating it's PassRefPtr<Widget> return value or with the caller of
createJavaAppletWidget whom mishandles the value.   In Qt 4.5.3 this method
returned *Widget and worked.

Of note: returning like so on 1330 causes a Seg Fault:
    return createPlugin(pluginSize, element, baseURL, paramNames, paramValues,
"application/x-java-applet", true);

    createPlugin(pluginSize, element, baseURL, paramNames, paramValues,
"application/x-java-applet", true);
    return 0;
Doesn't work (will not even spark a JVM in the tray), but doesn't seg fault

This is what is shown in gdb at crash during a seg fault... 
Thread 1 (thread 2712.0xac):
#0  0x00000000 in ?? ()
#1  0x6da936d6 in
npjp2!_Java_sun_plugin2_main_server_MozillaPlugin_getProxy0 at 20 () from
C:\Program Files (x86)\Java\jre6\bin\new_plugin\npjp2.dll
#2  0x48259e37 in ?? ()
#3  0x00000000 in ?? ()

Obviously I'm struggling here, I sure could use a hand from someone with more
C++ troubleshooting expertise. [I can post my Qt 4.6.2 build tree (w/ full
debug symbols enabled), if that would be helpful.]

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list