[Webkit-unassigned] [Bug 34852] Refactor parsing/serialization functions in HTMLInputElement

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Feb 13 12:02:36 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=34852


TAMURA, Kent <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED




--- Comment #3 from TAMURA, Kent <tkent at chromium.org>  2010-02-13 12:02:36 PST ---
(In reply to comment #2)
> (From update of attachment 48582 [details])
> I would prefer that we use references rather than pointers for the out
> arguments to all these functions.

As for the pointer arguments of parseToDoubleForNumberType() and
parseToDateComponents(), they are used for just check syntax of input stings,
and resultant double and DateCompnents are not used in that case.  So pointers
are reasonable.

> > +        Refacotr parsing/serialization functions in HTMLInputElement.
> Typo: Refacotr.

Fixed.

> > +        value. parseToDoubleForNumer() and parseToDateComponents()
> Typo: parseToDoubleForNuer.

Fixed.
I made too many typos...

> > +        functions are helper functions for it. serializeForCurrentType()
> > +        is the top-level function to serialize a double value to a
> > +        type-dependent string, and serializeForNumberType() and
> > +        serializeForDateTimeTypes() are helper functions for it.
> 
> I think serializeForCurrentType could be named just serialize.

ok, renamed to serialize().

> > +    ASSERT_NOT_REACHED();
> > +    return;
> > +}
> 
> It's not good style to have return at the end of the function. I suggest just
> leaving it out.

Removed.

> > +    default:
> > +        ASSERT_NOT_REACHED();
> > +        return String();
> >      }

Removed default:


Landed as r54754.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list