[Webkit-unassigned] [Bug 33967] [GTK] Mute/unmute button on <video> elements are backwards

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 12 02:30:44 PST 2010


Xan Lopez <xan.lopez at gmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |xan.lopez at gmail.com

--- Comment #6 from Xan Lopez <xan.lopez at gmail.com>  2010-02-12 02:30:44 PST ---
(In reply to comment #5)
> Or you could change the name to indicate the action they will take:
> m_willMuteButton, m_willPauseButton, etc.

I think considering how they are used:

return paintMediaButton(paintInfo.context, r, mediaElement->muted() ?
m_unmuteButton.get() : m_muteButton.get(), m_panelColor, m_mediaIconSize);

the names of the buttons are already OK (and consistent with the other
buttons). It's just that what they do when clicked is the opposite to the
status they should reflect, since they reverse themselves. So if we do what
comment #0 suggests at the end, or similar, we'd make one thing clear but the
other unclear (ie, the state would match the name but not the action).

So IMHO it's fine to just commit what the patch does, perhaps adding a small
comment explaining it.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list