[Webkit-unassigned] [Bug 34382] When a live iframe element is moved between pages, it still depends on the old page.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Feb 11 12:04:33 PST 2010
https://bugs.webkit.org/show_bug.cgi?id=34382
David Levin <levin at chromium.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #48547|review? |review+
Flag| |
--- Comment #16 from David Levin <levin at chromium.org> 2010-02-11 12:04:31 PST ---
(From update of attachment 48547)
1. I would remove all notImplemented(); I believe these imply that there is a
missing implementation, but that is not the case here. The ports with empty
methods simply don't need an implementation as far as we know.
2. I'm concerned about the change in WebKit/qt/Api/qwebframe.h. Does this mean
that the public api in qt is changing? It looks like Kenneth Rohde Christiansen
< kenneth at webkit.org> has been looking at these changes. Perhaps you could get
him to look at this part of your patch.
r=me after kenneth gives an ok (and it would be nice to address the other
things mentioned).
> diff --git a/WebCore/ChangeLog b/WebCore/ChangeLog
> +2010-02-10 Dmitry Titov <dimich at chromium.org>
> +
> + Reviewed by NOBODY (OOPS!).
> +
> + When a live iframe element is moved between pages, it still depends on the old page.
> + https://bugs.webkit.org/show_bug.cgi?id=34382
> +
> + Test: fast/frames/iframe-reparenting-new-page.html
> +
> + * html/HTMLFrameElementBase.cpp:
> + (WebCore::HTMLFrameElementBase::setName):
> + Move the code setting the frame name into a separate function.
> +
> + (WebCore::HTMLFrameElementBase::setNameAndOpenURL):
> + (WebCore::HTMLFrameElementBase::updateOnReparenting):
> + Called on the frame that was just re-parented and inserted into another Document.
> + Simply invoke Frame::updateOnreparenting(newParentFrame);
updateOnReparenting
^ capital R
In WebKit/chromium/ChangeLog
> + if Frame moves between Pages the client of corresponding WebFrame
> + should be replaced as well.
add a "," after Pages.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list