[Webkit-unassigned] [Bug 34019] Custom-written JavaScript parser
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Feb 1 12:26:51 PST 2010
https://bugs.webkit.org/show_bug.cgi?id=34019
Oliver Hunt <oliver at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #47711|review? |review-
Flag| |
--- Comment #33 from Oliver Hunt <oliver at apple.com> 2010-02-01 12:26:48 PST ---
(From update of attachment 47711)
I really don't like the top(-n) stuff. I would much rather all were replaced
with pop(), etc.
I think if there isn't a performance hit it would be _much_ clearer to have all
code be of the form
GrammarStackItem rhs = pop();
GrammarStackItem lhs = pop();
push(new AddNode(lhs, rhs));
Or whatever, rather than
top(-2) = new AddNode(top(-1), top(-2));
pop();
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list