[Webkit-unassigned] [Bug 51450] Glyphs in vertical text tests are rotated 90 degrees clockwise on Chromium Windows

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 29 06:59:41 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=51450


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #77598|review?                     |review-
               Flag|                            |




--- Comment #6 from Kent Tamura <tkent at chromium.org>  2010-12-29 06:59:41 PST ---
(From update of attachment 77598)
View in context: https://bugs.webkit.org/attachment.cgi?id=77598&action=review

Thank you for making the patch.
Would you attach some layout test result images please?

> WebCore/platform/graphics/chromium/FontCacheChromiumWin.cpp:573
> +FontPlatformData* FontCache::createFontPlatformData(const FontDescription& fontDescription, const AtomicString& oldFamily)

I don't think "oldFamily" is an appropriate name. 
How about keeping it as "family", and ...

> WebCore/platform/graphics/chromium/FontCacheChromiumWin.cpp:583
> +    AtomicString family;

.. renaming this to "updatedFamilyName" and replacing the following "family" with "updatedFamilyName"?

> WebCore/platform/graphics/chromium/FontCacheChromiumWin.cpp:586
> +    // Create FontPlatformData should consider the orientation.
> +    // For vertical: add "@" in front of the oldFamily name. (Windows)

This comment doesn't add any additional information.  Please remove it.

> WebCore/platform/graphics/chromium/FontPlatformDataChromiumWin.h:73
> -    FontOrientation orientation() const { return Horizontal; } // FIXME: Implement.
> +    FontOrientation orientation() const { return m_orientation; } // FIXME: Implement.

Please remove the FIXME comment.

> WebCore/platform/graphics/skia/FontCustomPlatformData.cpp:83
> +    // Create FontCustomPlatformData should consider the orientation.
> +    // For vertical: add "@" in front of the m_name. (Windows)

This comment doesn't add any additional information.  Please remove it.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list