[Webkit-unassigned] [Bug 48077] HTMLParserScheduler should be suspended when page loading is deferred

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 21 08:02:05 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=48077





--- Comment #26 from Yong Li <yong.li.webkit at gmail.com>  2010-12-21 08:02:05 PST ---
(In reply to comment #25)
> (From update of attachment 73422 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=73422&action=review
> > WebCore/dom/DocumentParser.h:95
> > +    virtual void willDeferLoading();
> > +    virtual void didResumeLoading();
> These really want to be named suspend and resume, respectively.  The only problem is that calling suspend doesn't actually suspend the parser.  It just stops the parser from running its scheduled callback.
> I think the code content of this patch is fine, I'm just struggling to find the right names for these functions.  I don't want to hold your patch hostage any longer, but we might want to come back and think of better names here.  Maybe add a FIXME comment?

How about suspendScheduledTasks()? Like what is being used in Bug 49401's patch

> > WebCore/page/PageGroupLoadDeferrer.cpp:54
> >                      frame->document()->suspendActiveDOMObjects(ActiveDOMObject::WillShowDialog);
> >                      frame->document()->asyncScriptRunner()->suspend();
> > +                    if (DocumentParser* parser = frame->document()->parser())
> > +                        parser->willDeferLoading();
> I understand that you don't want to add a FIXME for grouping these operations, but can you add a FIXME about moving this work to Document at some point?

Would you also like to take a look at Bug 49401? In that patch, I moved these calls to FrameLoader::setDefersLoading()

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list