[Webkit-unassigned] [Bug 50827] [GTK] Add APIs for plugin management

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Dec 11 02:57:13 PST 2010


Xan Lopez <xan.lopez at gmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |xan.lopez at gmail.com

--- Comment #4 from Xan Lopez <xan.lopez at gmail.com>  2010-12-11 02:57:14 PST ---
(In reply to comment #2)

I've pretty much done everything you asked for except...

> > WebKit/gtk/tests/testwebplugindatabase.c:37
> > +    WebKitWebPluginDatabasePluginList l;
> > +    GSList* p;
> These should probably be called pluginList and current. If possible in this language, they should be defined where they are first used, otherwise I'd say intialize them to 0.

I left 'p' as it is, as IMHO using that letter for list iterators is more or less as common as using 'i' for integer counters. Also no initialization to 0, since both variables are set to an initial value right away.

I've also used a RefPtr for the PluginPackage inside WebKitWebPlugin, as discussed yesterday in person.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list