[Webkit-unassigned] [Bug 50663] Support validation API for <object>

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 8 19:23:05 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=50663





--- Comment #4 from Kenichi Ishibashi <bashi at google.com>  2010-12-08 19:23:05 PST ---
(From update of attachment 75997)
View in context: https://bugs.webkit.org/attachment.cgi?id=75997&action=review

Kent-san,

Thank you for your prompt review. I'll post revised patch after the title of this bug changes.

>> LayoutTests/fast/forms/ValidityState-001-expected.txt:7
>>  SUCCESS
> 
> The test result readability is bad.
> However it's ok.  You just followed the existing test.

I've added tagName for each line.

>> LayoutTests/fast/forms/checkValidity-001-expected.txt:10
>>  PASS v[i].checkValidity() is true
> 
> ditto.

Modified to use the same representation that you suggested in the below comment.

>> LayoutTests/fast/forms/script-tests/setCustomValidity-existence.js:19
>> +        shouldBe('typeof controls[i].setCustomValidity', '"function"');
> 
> The indentation looks wrong.
> 
> The test result readability is not good.
> shouldBe('document.getElementsByTagName("input")[0].setCustomValidity', '"function"');
> shouldBe('document.getElementsByTagName("textarea")[0].setCustomValidity', '"function"');
> ...
> is better.

I've modified them following your suggestion. Thanks!

>> LayoutTests/fast/forms/willvalidate-expected.txt:51
>> +FAIL document.getElementsByTagName("keygen")[0].willValidate should be false. Was true.
> 
> We should remove test cases for keygen, or should expand this bug so that it includes <keygen> fix.

I'd like to include the fix for <keygen> in this bug, so could you change the title of this bug something like "Improve validation API support on <object> and <keygen>" or more appropriate one?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list