[Webkit-unassigned] [Bug 50617] ValidityState's exposed functions should check if willValidate() is true before all

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 7 20:08:17 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=50617


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #75862|review?                     |review-
               Flag|                            |




--- Comment #4 from Kent Tamura <tkent at chromium.org>  2010-12-07 20:08:18 PST ---
(From update of attachment 75862)
View in context: https://bugs.webkit.org/attachment.cgi?id=75862&action=review

> LayoutTests/ChangeLog:9
> +        * fast/forms/ValidityState-patternMismatch-008-expected.txt: Added.
> +        * fast/forms/ValidityState-patternMismatch-008.html: Added.

"008" represents nothing about the content.  Do not add files with such cryptic names.
Existing ValidityState-patternMismatch-00x should be renamed and we can merge them into one.

> LayoutTests/fast/forms/script-tests/ValidityState-typeMismatch-date.js:28
> +function shouldBeInvalid(value, disabled)
>  {
> -    check(value, true);
> +    check(value, true, disabled);

We don't need to add "disabled" parameter to shouldBeInvalid().  It is not used.

> LayoutTests/fast/forms/script-tests/ValidityState-typeMismatch-datetime.js:28
> -function shouldBeInvalid(value)
> +function shouldBeInvalid(value, disabled)
>  {
> -    check(value, true);
> +    check(value, true, disabled);

ditto.

> LayoutTests/fast/forms/script-tests/ValidityState-typeMismatch-datetimelocal.js:28
> -function shouldBeInvalid(value)
> +function shouldBeInvalid(value, disabled)
>  {
> -    check(value, true);
> +    check(value, true, disabled);

ditto.

> LayoutTests/fast/forms/script-tests/ValidityState-typeMismatch-month.js:28
> -function shouldBeInvalid(value)
> +function shouldBeInvalid(value, disabled)
>  {
> -    check(value, true);
> +    check(value, true, disabled);

ditto.

> LayoutTests/fast/forms/script-tests/ValidityState-typeMismatch-time.js:28
> -function shouldBeInvalid(value)
> +function shouldBeInvalid(value, disabled)
>  {
> -    check(value, true);
> +    check(value, true, disabled);

ditto.

> LayoutTests/fast/forms/script-tests/ValidityState-typeMismatch-url.js:23
> -function expectInvalid(value) {
> -    check(value, true);
> +function expectInvalid(value, disabled) {
> +    check(value, true, disabled);

ditto.

> LayoutTests/fast/forms/script-tests/ValidityState-typeMismatch-week.js:28
> -function shouldBeInvalid(value)
> +function shouldBeInvalid(value, disabled)
>  {
> -    check(value, true);
> +    check(value, true, disabled);

ditto.

> WebCore/ChangeLog:12
> +        * html/ValidityState.cpp:

We need to update ValidityState::customError() in ValidityState.h too.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list