[Webkit-unassigned] [Bug 45443] [GTK] Support for viewport meta tag

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Dec 7 11:47:01 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=45443


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #75721|review+                     |review-
               Flag|                            |




--- Comment #70 from Martin Robinson <mrobinson at webkit.org>  2010-12-07 11:47:00 PST ---
(From update of attachment 75721)
View in context: https://bugs.webkit.org/attachment.cgi?id=75721&action=review

> WebKit/gtk/WebCoreSupport/DumpRenderTreeSupportGtk.cpp:382
> +void DumpRenderTreeSupportGtk::computeViewportAttributesForSize(WebKitWebView* webView, gint availableWidth, gint availableHeight)

I think this should called dumpConfigurationViewport.

> WebKit/gtk/webkit/webkitviewportattributes.cpp:216
> +     * WebKitViewportAttributs:desktop-width:

Move the default below here and the comment into the documentation.

> WebKit/gtk/webkit/webkitviewportattributes.cpp:239
> +     * WebKitViewportAttributs:device-dpi:

Set the default here and also move the comments below into the documentation. Maybe clean up the line breaking a little.

> WebKit/gtk/webkit/webkitviewportattributes.cpp:266
> +     * The width of the viewport.
> +     * Before getting this property, you need to make sure that 
> +     * #WebKitViewportAttributes is valid.

Maybe clean up these line breaks a little.

> WebKit/gtk/webkit/webkitviewportattributes.cpp:427
> +static void webkit_viewport_attributes_get_property(GObject* object, guint prop_id, GValue* value, GParamSpec* pspec)

Expand the abbreviations in these variable names.

> WebKit/gtk/webkit/webkitviewportattributes.cpp:481
> +static void webkit_viewport_attributes_set_property(GObject* object, guint prop_id, const GValue* value, GParamSpec *pspec)

Same here and move the asterisk.

> WebKit/gtk/webkit/webkitviewportattributes.cpp:527
> +    // This value works well for most web pages designed for desktop browsers.
> +    priv->desktopWidth = 980;
> +    // It is the dpi of the original iPhone and Android devices.
> +    priv->deviceDPI = 160;

Change these into default property variables.

> WebKit/gtk/webkit/webkitviewportattributes.cpp:550
> +    // Now let the application know it is safe to use the new
> +    // values.

This can be one line.

> WebKit/gtk/webkit/webkitwebview.cpp:-176
> -

I think you can remove this line deletion.

> WebKit/gtk/webkit/webkitwebview.cpp:2737
> +     * The #WebKitWebView::viewport-attributes-recompute-requested
> +     * signal will be emitted whenever recomputing the values of the
> +     * viewport attributes is required. That may happen because the
> +     * viewport meta tag of a page has changed, or it may happen as a
> +     * consequence of an explicit browser request (caused by screen
> +     * rotation, resizing, or similar reasons).

The #WebKitWebView::viewport-attributes-recompute-requested signal will be emitted when a page with a viewport metatag loads and when webkit_recompute_viewport_attributes is called.

> WebKit/gtk/webkit/webkitwebview.cpp:2753
> +            NULL, NULL,

These should be 0's.

> WebKit/gtk/webkit/webkitwebview.cpp:2766
> +     * The #WebKitWebView::viewport-attributes-available will be emitted with @viewport_attributes
> +     * when the viewport attributes are updated in the case of loading web pages contain
> +     * the viewport properties and calling webkit_viewport_attributes_recompute.
> +     * @viewport_attributes is used to control the viewport layout to make a web page fit the device screen.

The #WebKitWebView::viewport-attributes-(changed or updated or recomputed) signal will be emitted after the emission of #WebKitWebView::viewport-attributes-recompute-requested and the subsequent viewport attribute recomputation. At this point, if the WebKitViewportAttributes are valid, the viewport attributes are available.

> WebKit/gtk/webkit/webkitwebview.cpp:2774
> +            NULL, NULL,

These should be 0's.

> WebKit/gtk/webkit/webkitwebview.cpp:3612
> + * #WebKitWebViewpor_Attributes object attached to it as soon as it is

#WebKitWebViewportAttributes

> WebKitTools/DumpRenderTree/LayoutTestController.h:288
> +    void configurationForViewport(int availableWidth, int availableHeight);

This should be called dumpConfigurationForViewport.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list