[Webkit-unassigned] [Bug 49907] Better result passing in filter primitives

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 6 00:30:24 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=49907





--- Comment #17 from Zoltan Herczeg <zherczeg at webkit.org>  2010-12-06 00:30:23 PST ---
> > WebCore/platform/graphics/filters/FilterEffect.h:58
> > +    PassRefPtr<ImageData> asUnmultipliedImage(const IntRect&);
> > +    PassRefPtr<ImageData> asPremultipliedImage(const IntRect&);
> > +    void asUnmultipliedImage(ImageData* dst, const IntRect&);
> > +    void asPremultipliedImage(ImageData* dst, const IntRect&);

Renamed to copyUnmultipliedImage and copyPremultipliedImage.

About the renamings, bottoms(), etc.: As Krit said, they all come from the GraphicsContext (platform dependent) implementation, and perhaps they should be renamed there as well (they probably copied the mac code). Unfortunately there are lots of platforms.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list