[Webkit-unassigned] [Bug 50082] [Qt] Use QNetworkAccessManager zerocopy feature from QNetworkReplyHandler

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 2 06:44:50 PST 2010


https://bugs.webkit.org/show_bug.cgi?id=50082


Kenneth Rohde Christiansen <kenneth at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #75372|review?                     |review-
               Flag|                            |




--- Comment #6 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2010-12-02 06:44:50 PST ---
(From update of attachment 75372)
View in context: https://bugs.webkit.org/attachment.cgi?id=75372&action=review

> WebCore/platform/SharedBuffer.h:45
>  #endif
> +#endif

I trust you that this is git showing the diff wrong... if not, you need to fix it

> WebCore/platform/network/qt/QNetworkReplyHandler.cpp:237
> +    // Then this buffer is provided to us in the QNetworkReply

Where is the dot!

> WebCore/platform/network/qt/QNetworkReplyHandler.cpp:240
> +
> +

No need for two newlines here

> WebCore/platform/network/qt/QNetworkReplyHandler.cpp:376
> +        m_usingZeroCopy = true;

Please rename m_usingZeroCopy to m_usingZeroCopyFeature

> WebCore/platform/network/qt/QNetworkReplyHandler.cpp:503
> +                           oldSize, bytesReceived - oldSize, bytesReceived - oldSize);

I would keep oldSize on the line above

> WebCore/platform/network/qt/ResourceHandleQt.cpp:180
> -    return false;
> +    return true;

Shouldnt there be a "if usingZeroCopyFeature" here?

> WebCore/platform/qt/QByteBlock.cpp:46
> +    return (const char*)(m_data.data());

Remove latter ()

> WebCore/platform/qt/SharedBufferQt.cpp:50
> +    SharedBuffer* sb = new SharedBuffer();

Shouldn't this be RefPtr<SharedBuffer*> sb = new SharedBuffer() ?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list