[Webkit-unassigned] [Bug 44939] Web Inspector: move debugger tests to the new test harness

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 31 09:27:23 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=44939





--- Comment #4 from Pavel Podivilov <podivilov at chromium.org>  2010-08-31 09:27:23 PST ---
(In reply to comment #2)
> (From update of attachment 66026 [details])
> btw, what's the point in switching debugger tests to inspector-tests2.js?
The point was to fully support tests that require page reloading.
Also, other tests are easier with new test harness.

> 
> > LayoutTests/http/tests/inspector/inspector-test2.js:164
> > +    dumpedResultsCount = results.length;
> Please keep this counter on the front-end(or even get rid of it completely) and slice results array before passing it here.
done

> 
> > LayoutTests/inspector/debugger-cyclic-ref-expected.txt:4
> > -Set timer for test function.
> Why is this gone?
restored

> 
> > LayoutTests/inspector/debugger-cyclic-ref.html:13
> > -    notifyDone();
> This should be called after we left debugger code, you cannot simply invoke this code from the front-end(see the change that introduced this line). r- for that.
> 
> > LayoutTests/inspector/debugger-eval-while-paused.html:12
> > -    notifyDone();
> This should be reverted.
InspectorTest.completeDebuggerTest always waits for WebInspector.resumedScript call before closing inspector. WebInspector.resumedScript is called from InspectorDebuggerAgent::didContinue which is outside nested message loop.
So it should be safe to use completeDebuggerTest function.

> 
> > LayoutTests/inspector/debugger-no-nested-pause.html:11
> > -    if (testFunction.didExitFromNestedCall)
> Now the test will pass even if testFunction is executed only once.
We dump invocationCount at the end of the test, so the test won't actually pass in that case.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list