[Webkit-unassigned] [Bug 44939] Web Inspector: move debugger tests to the new test harness

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 31 05:17:43 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=44939


Yury Semikhatsky <yurys at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #66026|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #2 from Yury Semikhatsky <yurys at chromium.org>  2010-08-31 05:17:42 PST ---
(From update of attachment 66026)
btw, what's the point in switching debugger tests to inspector-tests2.js?

> LayoutTests/http/tests/inspector/inspector-test2.js:164
> +    dumpedResultsCount = results.length;
Please keep this counter on the front-end(or even get rid of it completely) and slice results array before passing it here.

> LayoutTests/inspector/debugger-cyclic-ref-expected.txt:4
> -Set timer for test function.
Why is this gone?

> LayoutTests/inspector/debugger-cyclic-ref.html:13
> -    notifyDone();
This should be called after we left debugger code, you cannot simply invoke this code from the front-end(see the change that introduced this line). r- for that.

> LayoutTests/inspector/debugger-eval-while-paused.html:12
> -    notifyDone();
This should be reverted.

> LayoutTests/inspector/debugger-no-nested-pause.html:11
> -    if (testFunction.didExitFromNestedCall)
Now the test will pass even if testFunction is executed only once.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list