[Webkit-unassigned] [Bug 43658] Calling window.print() before the page is loaded results in a blank printed page

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 30 17:48:15 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=43658


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |darin at apple.com




--- Comment #16 from Darin Adler <darin at apple.com>  2010-08-30 17:48:14 PST ---
I see multiple problems with this patch:

It’s not good how this patch spreads the feature over two classes. The code in both FrameLoader and DOMWindow is inelegant. All the code should be in one class, with the other class calling over as needed. That way you would not have to expose a printDeferred function.

The name printDeferred is not a good boolean function or data member name. It sounds like a verb "print deferred". I would name it "should print when finished loading":

    m_shouldPrintWhenFinishedLoading

Also, I think FrameLoader::finishedLoading may not be the right place to call this. That's the function called when the main resources is loaded, not when the entire page is loaded.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list