[Webkit-unassigned] [Bug 44433] Add AsyncFileSystem interface for platform-dependent FileSystem API implementation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 26 23:25:33 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=44433


Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #65524|review?                     |review+, commit-queue-
               Flag|                            |




--- Comment #17 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2010-08-26 23:25:33 PST ---
(From update of attachment 65524)
WebCore/platform/AsyncFileSystem.h:62
 +      static void openFileSystem(const String& basePath, const String& storageIdentifier, Type, PassOwnPtr<AsyncFileSystemCallbacks>);
I don't understand the comment about passing ownership of 'this' since this method is static.  There is no 'this' pointer.

WebCore/platform/AsyncFileSystemCallbacks.h:57
 +      virtual void didReadDirectoryChunkDone(bool hasMore) = 0;
The name of this method is a bit awkward sounding.  Perhaps didReadDirectoryEntries would be a better name?  Pluralizing Entry suggests a "chunk of entries", which seems similar to what you were trying to get at with using Chunk in the name.  Also, the Done bit may be redundant with the hasMore parameter, so leaving it as didReadDirectoryEntries seems reasonable to me.  It just informs the callbacks that entries were read and more may be read soon.  Works for me!


R=me w/ these two changes.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list