[Webkit-unassigned] [Bug 44466] Fix gcc warning introduced in 65731

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 24 01:55:57 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=44466





--- Comment #3 from Csaba Osztrogonac <ossy at webkit.org>  2010-08-24 01:55:57 PST ---
-        mask = mask | (mask >> domBreakpointDerivedTypeShift) & ((1 << domBreakpointDerivedTypeShift) - 1);
+        mask = (mask | (mask >> domBreakpointDerivedTypeShift)) & ((1 << domBreakpointDerivedTypeShift) - 1);

I don't understand what should this code do, but adding 
parantheses like this, will change the behaviour of the code.
Which one is wrong? The original or the modified?

a | b & c is equal to a | (b & c) , because & has higher precedence than |

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list