[Webkit-unassigned] [Bug 41486] rietveld review output is difficult to read
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Aug 23 15:44:25 PDT 2010
https://bugs.webkit.org/show_bug.cgi?id=41486
--- Comment #1 from Ojan Vafai <ojan at chromium.org> 2010-08-23 15:44:25 PST ---
I've changed the output so it will look like the following (grabbed off my local server). I hope this addresses all of Darin's concerns. There's a few integration issues with the upload bot. Once those are resolved, we should be able to test out people optionally using rietveld again.
codereview/views.py(right) http://localhost:8080/1000/diff/1/2
Lines 941-942:
> html = "<body style='margin:0'><a href='%s?webkit_patch_id=%s'>%s</a></body>" % (
> issue_url, webkit_patch_id, "Rietveld Review")
This is gross. Don't put HTML into your python. Make this a template instead.
Lines 971-976:
>
> raw_webkit_patch_id = form.cleaned_data['webkit_patch_id']
> if raw_webkit_patch_id:
> webkit_patch_id = str(raw_webkit_patch_id)
> else:
> form.errors['webkit_patch_id'] = ['Need a patch id for webkit patches.']
This is a comment.
Line 996:
> issue = _make_new(request, form, issue_id, webkit_patch_id)
This is a one line comment.
upload.py(right) http://localhost:8080/1000/diff/1/6
Line 510:
> group.add_option("--webkit_patch_id", action="store", dest="webkit_patch_id",
This is a second file comment.
Line 1706:
> form_fields.append(("webkit_patch_id", str(options.webkit_patch_id)))
Here's a comment in another file.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list