[Webkit-unassigned] [Bug 42886] Web Inspector: implement DOM breakpoints

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 20 06:29:11 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=42886





--- Comment #27 from Pavel Podivilov <podivilov at chromium.org>  2010-08-20 06:29:11 PST ---
(In reply to comment #25)
> (From update of attachment 64945 [details])
> WebCore/inspector/InspectorDOMAgent.cpp:1066
>  +      if (!node)
> You don't seem to need this check.
done

> WebCore/inspector/InspectorDOMAgent.cpp:1064
>  +  void InspectorDOMAgent::updateSubtreeBreakpoints(Node* node, long mask, bool set)
> I'd rename mask to rootMask or something that would reflect the fact that it's not shifted.
done

> WebCore/inspector/InspectorDOMAgent.h:218
>  +          HashMap<Node*, long> m_breakpoints;
> Why not have int as value type? We use only 32 bits in the code anyway.
For both int and long types size is not guaranteed
long -> uint32_t

> WebCore/inspector/InspectorDOMAgent.cpp:1060
>  +      return s_domAgentOnBreakpoint != 0;
> Please reset s_domAgentOnBreakpoint to 0 before leaving this method.
done

> WebCore/bindings/v8/ScriptDebugServer.cpp:243
>  +      v8::Handle<v8::Context> context = v8::Context::GetCurrent();
> Isn't it Debugger context?
This method is called from javascript callbacks.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list