[Webkit-unassigned] [Bug 43151] [chromium] Add WebKit API for HTML5 FileSystem API

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 18 11:42:30 PDT 2010


--- Comment #26 from Kinuko Yasuda <kinuko at chromium.org>  2010-08-18 11:42:29 PST ---
Thanks for reviewing.   All fixed as suggested.  (Please ignore the chromium build failure for now.)

(In reply to comment #21)
> WebKit/chromium/public/WebFileSystemCallbacks.h:47
>  +      virtual void onSuccess() = 0;
> nit: we use the naming scheme didFoo instead of onFoo in the webkit api.
> it is also nice to try to make the names read as a phrase.  instead of
> "on success blah", which isn't good grammar, you'd write "did finish
> doing blah" or something like that.

Changed the method names to did + verb.

> i'm not sure if didOpenFileSystem is the best name.  i was trying to
> come up with a good verb.  didRequestFileSystem doesn't seem quite right
> because the verb should describe the result of the request.  i guess
> the result of requestFileSystem is to be able to use the file system,
> which is sort of what "opening" the file system might mean.  maybe we
> should rename "requestFileSystem" to "openFileSystem".

openFileSystem sounds good to me.  (Confirmed that the verb sounds relevant to what it does to @ericu too)
I changed WebFrameClient::requestFileSystem to openFileSystem as well.

> WebKit/chromium/public/WebFileSystemEntry.h:38
>  +  struct WebFileSystemEntry {
> i'm curious why you went with WebFileSystemEntry instead of WebFileEntry.
> on one hand, it seems nice to scope *Entry to WebFileSystem since it
> represents an entry in the file system.  on the other hand, the spec
> just uses "FileEntry" for this.  and, WebFileEntry seems descriptive
> enough.

Renamed it to WebFileEntry... no one would love longer names when shorter one is enough.
(FileEntry in the spec specifically means the entry is a regular file but not a directory, so it has a bit different meaning.)

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list