[Webkit-unassigned] [Bug 43453] [chromium] The chromium API needs a WebMouseEvent class

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 17 11:12:52 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=43453


Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #64411|review?                     |review-
               Flag|                            |




--- Comment #14 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2010-08-17 11:12:52 PST ---
(From update of attachment 64411)
WebKit/chromium/public/WebNode.h:102
 +      WEBKIT_API void addDOMEventListener(const WebString& eventType, WebDOMEventListener* listener, bool useCapture);
nit: these should just be named add/removeEventListener to match
how they are named in the DOM specification.

WebKit/chromium/src/EventListenerWrapper.h:50
 +  class EventListenerWrapperDOM : public EventListener {
EventListenerWrapperDOM is an awkward name.  can we rename the other
one DeprecatedEventListenerWrapper, and then use EventListenerWrapper?

otherwise, LGTM

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list