[Webkit-unassigned] [Bug 43264] Web Inspector: inspector tests should be frontend-driven

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 17 03:16:44 PDT 2010


--- Comment #3 from Yury Semikhatsky <yurys at chromium.org>  2010-08-17 03:16:44 PST ---
(From update of attachment 63088)
 +          "if (!InspectorTest) {",
!window.InspectorTest, otherwise you'll get an exception.

 +      layoutTestController.evaluateInWebInspector(completeTestCallId, "true");
This roundtrip shouldn't be needed(at least at the new tests).

 +  function createKeyEvent(keyIdentifier)
Let's move all these methods on to InspectorTest object so that it's easy to distinguish test methods from the rest of front-end methods.

 +  InspectorTest.push = function(text)
maybe rename it to addResult?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list