[Webkit-unassigned] [Bug 43993] Add idl and mock classes for FileSystem API's {File, Directory}Entry and related interfaces
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Aug 16 15:24:34 PDT 2010
https://bugs.webkit.org/show_bug.cgi?id=43993
--- Comment #5 from Kinuko Yasuda <kinuko at chromium.org> 2010-08-16 15:24:33 PST ---
(In reply to comment #4)
> Thanks for reviewing.
>
> (In reply to comment #2)
> > (From update of attachment 64380 [details] [details])
> > WebCore/ChangeLog:14
> > + * WebCore.xcodeproj/project.pbxproj:
> > you need to add these new files to a whole lot more build files (and possibly JSDerivedSources too): see http://trac.webkit.org/changeset/61531
>
> Fixed. I also added entries for basic idls/classes added in changeset 64414.
> I was assuming we wouldn't need to include them on other platforms yet but on the second thought not having them on some platforms might be confusing.
>
> > WebCore/storage/DirectoryEntry.cpp:54
> > + // FIXME: to be implemented.
> > might be worth adding ASSERT_NOT_REACHED() to all methods that are not yet implemented.
>
> Added.
>
> > WebCore/storage/DirectoryEntry.idl:38
> > + void getFile(in DOMString path, in [Optional] Flags options, in [Optional, Callback] EntryCallback successCallback, in [Optional, Callback] ErrorCallback errorCallback);
> > will "[Optional] Flags options" generate "RefPtr<Flags> options;" or just "Flags* options"?
>
> Yes.
Oops, I meant: it generates RefPtr<Flags> options (PassRefPtr for args).
Do you mean creating ref-counted objects for such flags might be too much? Currently I don't have a good idea how we should treat those super lightweight (but not directly mapped to a native type) interfaces.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list